Xcode UI Testing "Error al intentar iniciar"

Soy nuevo en las testings de interfaz de usuario y estoy tratando de integrar la function en un proyecto existente. Estoy probando las testings más básicas para ver el marco en acción, pero estoy teniendo dificultades. Agregué un nuevo objective de UI Testing Bundle a mi proyecto y puedo ejecutar mi testing básica. Sin embargo, sigo recibiendo un error "Error al intentar iniciar" que siempre ocurre cuando estoy intentando realmente iniciar la aplicación en mi testing. También dice algo sobre un "token cero para la reference de process actual".

Aquí está el código que estoy probando:

@implementation SKYPracticeUITesting - (void)setUp { [super setUp]; // Put setup code here. This method is called before the invocation of each test method in the class. // In UI tests it is usually best to stop immediately when a failure occurs. self.continueAfterFailure = NO; // UI tests must launch the application that they test. Doing this in setup will make sure it happens for each test method. XCUIApplication *app = [[XCUIApplication alloc] init]; // In UI tests it's important to set the initial state - such as interface orientation - requinetworking for your tests before they run. The setUp method is a good place to do this. [app launch]; } - (void)tearDown { // Put teardown code here. This method is called after the invocation of each test method in the class. [super tearDown]; } - (void)testExample { // Use recording to get started writing UI tests. // Use XCTAssert and related functions to verify your tests produce the correct results. NSLog(@"Something is happening"); } @end 

Cualquier ayuda sería muy apreciada, especialmente considerando que el process en Objective-C no está muy bien documentado.