Xcode 6 no me deja desarrollar en mi teléfono iOS 8

Estaba desarrollando una aplicación con iOS 7 y acabo de actualizar a la versión beta de iOS 8. Descargué Xcode 6 beta y ahora cuando conecto mi teléfono, muestra mi teléfono en "Dispositivos no aptos" y no me deja desarrollar en eso. ¿Por qué es esto?

Acabo de tener el mismo problema. Lo que me solucionó fue cambiar el objective de implementación (aunque en mi caso pasé de 8 a 7).