Xcode 6 Beta – Error de Apple Mach-O Linker

Después de actualizar a la beta 6 recientemente publicada de Xcode 6, mi proyecto rápido no se puede build debido a los siguientes errores.

Xcode 6 Beta 6 problema

En cuanto a las preguntas anteriores sobre este tema, propongo que se compruebe que la architecture de construcción está configurada para soportar el arm que el proyecto de la mina ya incluye (arm64, armv7s, armv7).

Primero, asegúrese de tener instalada la beta más reciente. Luego borre su carpeta DerivedData (~ / Library / Developer / Xcode / DerivedData). Esto debería permitirle comstackr nuevamente en la versión beta más reciente.

Edit: Esto parece ser cierto también para la nueva versión beta de Xcode también

Por lo que escucho, hasta el momento Xcode 6 Beta 6 está roto. Debe desinstalar y retroceder a Beta 5.

Edit: Al parecer, una nueva versión ya está disponible, solo reinstala la beta 6

http://9to5mac.com/2014/08/18/apple-re-releases-xcode-6-beta-6-solves-issues-discovenetworking-by-developers-in-new-build/

Asegúrese de instalar la última versión de Xcode Beta 6. Si marca Xcode-> Acerca de Xcode, debería ver: Version 6.0 (6A280e)

Yo tuve el mismo problema. He reinstalado Xcode. Entonces solucionó el problema. En mi caso sucedió debido a la eliminación de un marco importado (mover a la papelera) que está dentro de mi browser de proyecto. Creo que Xcode elimina todo el marco cuando eliminamos (pasamos a la basura) el marco importado de nuestro browser de proyectos.

Asegúrese de no haber hecho ningún ejemplo de importaciones innecesarias importando un file .h cuando necesitaba .m