xcode 4.5 ejecuta ios 4.0 simulator (NOT)

Acabo de actualizar a iOS 6 xcode 4.5
Pero descubrí que incluso en Xcode-reference-download solo hay ios 5,6
Prefiero que mi aplicación funcione también para los usuarios que utilizan iOS 4.X

Cualquier comentario es bienvenido.

Si estás en Lion, puedes download el simulador 4.3 (al less lo hice con la versión Gold Master, supuestamente todavía funciona con la versión final).

En Mountain Lion, el simulador 4.3 es buggy (como se ve en las primeras betas) y Apple lo ha eliminado.

Si realmente necesitas hacerlo, puedes ejecutar Lion sobre Moutain Lion con Parallels Desktop o algo similar, eso es lo que hago.

Puedo confirmar que funciona en Lion con Xcode 4.5 (Simulator 4.3)

introduzca la descripción de la imagen aquí

XCode 4.5.x solo admite la architecture armv7:

Cambios en Xcode 4.5.x para iOS 6

  1. Xcode 4.5.x (y posterior) no es compatible con la generación de binarys de armv6.
  2. Ahora incluye soporte para iPhone 5 / armv7s.
  3. El objective mínimo de implementación compatible con Xcode 4.5.xo posterior es iOS 4.3 .
  4. El soporte mínimo para iPhone es el iPhone 3GS o posterior, ya que las versiones anteriores usan armv6.

Espero que esto ayude….