Versión mínima de iOS compatible con c ++ 0x

Tengo un pequeño motor de juego escrito en c ++. Estoy considerando usar algunas características de c ++ 0x

¿Qué versión mínima de ios se requiere? ¿El nuevo estándar viene como una biblioteca dinámica adicional o solo está estáticamente vinculado?

Actualizar:

Estoy planeando usar lambdas, nuevo para ciclo y auto tipo deducción

Mooing Duck: quiero hacer y correr tanto.

El soporte de C ++ 11 en iOS está más o less restringido al comstackdor de Clang, que ha estado agregando características de C ++ 11 lentamente en varias versiones. La biblioteca estándar en iOS que admite C ++ 11 es libc++ , y está vinculada dinámicamente, por lo que las nuevas características que necesitan soporte estándar de la biblioteca tendrán versiones mínimas de SDK. En realidad, no fue hasta iOS 5 que Apple se sintió cómodo diciendo que C ++ 11 es compatible con el comstackdor, pero algunas características estaban disponibles antes. En última instancia, depende de la function que estés considerando, y la forma más sencilla de averiguarlo (ya que no tengo conocimiento de ninguna list de características y de qué versiones de iOS funcionan) es simplemente hacer una pequeña testing y intenta comstackrlo contra varias versiones de iOS SDK.