Validar una aplicación

Tengo el proyecto, fue hecho por otro progtwigdor. Descargué su versión y mi objective era agregar un código. No cambié nada en la configuration del proyecto, excepto en mis perfiles de provisiones. El objective de deployment es 5.1. Traté de validar con una nueva versión, pero tengo un problema:

Este package no es válido. Las aplicaciones que incluyen la architecture arm64 no pueden tener MinimumOSVersion configurado en less de '5.1.1'.

Pero la última actualización de la aplicación fue hecha por él hace 1.5 meses. Entonces, la pregunta es: ¿debo cambiar el objective de implementación a 6.0?

No puede establecer MinimumOSVersion a 5.1.1 hasta que elimine la architecture de arm64 de su aplicación.

Si necesita que su aplicación se base en arquitecto de arm64, establezca el mínimo de OS admitido en 7.0 o más.

De lo contrario, si necesita que su aplicación se ejecute en iOS 5.1.1, quite arm64 de su proyecto.