Uso del identificador no resuelto 'Realm'

Soy nuevo en el desarrollo de Realm y iOS y estoy atrapado debido a este error. Descargué la versión más reciente de Realm, es decir, 0.98.0 y seguí los pasos mencionados en la sección de Introducción

  1. Descarga la última versión de Realm y extrae el zip.
  2. Vaya a la configuration "General" de su proyecto Xcode. Arrastre RealmSwift.framework y Realm.framework desde el directory ios / swift-2.1.1 /, watchos /, tvos / o osx / swift-2.1.1 / a la sección "Binarios integrados". Asegúrese de seleccionar Copiar elementos si es necesario y click Finalizar.
  3. En la "Configuración de compilation" del objective de testing de la unidad, agregue la ruta principal a RealmSwift.framework en la sección "Rutas de búsqueda del marco".
  4. Si usa Realm en un proyecto iOS, watchOS o tvOS, cree una nueva "Run Script Phase" en el "Fases de compilation" de su aplicación y pegue el siguiente fragment en el campo de text del script:

    bash "$ {BUILT_PRODUCTS_DIR} / $ {FRAMEWORKS_FOLDER_PATH} /Realm.framework/strip-frameworks.sh"

Como se menciona en la respuesta a la siguiente pregunta, agregué $ (PROJECT_DIR) en las Rutas de búsqueda de Framework

¿Cómo agregar la ruta principal a RealmSwift.framework en la sección "Rutas de búsqueda de Framework"?

Después de eso, creé una class llamada Dog y agregué el siguiente código en AppDelegate.swift

let myDog = Dog() myDog.name = "Rex" myDog.age = 1 print("name of dog: \(myDog.name)") // Get the default Realm let realm = try! Realm() // Persist your data easily try! realm.write { realm.add(myDog) } 

Cuando trato de build el proyecto obtengo un error "Uso del identificador no resuelto 'Realm'" en la siguiente línea:

 let realm = try! Realm() 

He intentado crear nuevos proyectos y siguiendo cuidadosamente los pasos anteriores, pero aún recibo el error. Para el Paso 2 intenté agregar el marco con las opciones de "Crear grupos" y "Crear references de carpeta" manteniendo marcada la casilla "Copiar elementos si es necesario".

Estoy usando XCode 7.2.1, OS 10.11.13 y Swift 2.1.1. No tengo Cocoapods instalado en este momento.

¿Me estoy perdiendo un paso en alguna parte? Cualquier ayuda sería muy apreciada.

El problema fue la statement de import faltante. La carpeta de ejemplos ayudó a resolver el problema.

 import RealmSwift 

Después de haber trabajado con Java y la function de import automática en Eclipse, esto tardó un poco en acostumbrarse.