Usa Xcode 8 con iOS 11

Quiero usar Xcode 8 con iOS 11.

Debo actualizar mi Xcode. Sin embargo, el comstackdor nuevo no puede comstackr mi código, así que quiero quedarme con Xcode 8.

introduzca la descripción de la imagen aquí

¿Cómo puedo lograrlo?

Apple reveló varias características nuevas de iOS 11 en WWDC 2017.

Mira esto:

  1. Descargue este lanzamiento oficial de imageFile iOS 11 beta o iOS 11 :
  2. Copie este file de image de iOS 11.0 a: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/
  3. Reiniciar Xcode.

Publicación original: https://stackoverflow.com/a/41928402/4935811

Xcode8 no se pudo admitir a less que tenga la carpeta DeviceSupport para la versión iOS11.

1. puede download una beta de Xcode9 u get una carpeta de DeviceSupport de otro usuario.

2. Simplemente copie en su carpeta o cree un enlace simbólico

sudo ln -s /Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/11.0\ \(15A372\) /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/11.0

reference: usa Xcode 7 con iOS 10

Lo hice y está bien, todavía trabajo en la aplicación comercial usando Xcode 8 + Swift 3 y explorando Xcode 9 beta con Swift 4. Simplemente descargue Xcode 9 y, dentro de las preferences de Xcode 8, configure las Herramientas de línea de command para usar el 9.0 .

Preferencias de Xcode> Ubicaciones

Preferí copyr TODA la carpeta:

 /Volumes/**HighSierra**/Applications/Xcode-**beta.app**/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/11.0\ \(15A5278f\) 

a:

  /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/**11** 

Puedo confirmar que puedo ejecutar en mi iPhone 7 con iOS 11

Al parecer, puedes ejecutar iOS 11 con Xcode 8