Swift no es compatible con el SDK 'iPhoneSimulator8.4.sdk'

Acabo de actualizar a Xcode 7.0.1, ejecutándose en El Capitan (GM) con SIP deshabilitado. Y ahora cada vez que trato de comstackr un proyecto Swift recibo este error;

<unknown>:0: error: Swift does not support the SDK 'iPhoneSimulator8.4.sdk' Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/swiftc failed with exit code 1 

También intenté comstackr dispositivos reales y obtuve:

 <unknown>:0: error: Swift does not support the SDK 'iPhoneOS8.4.sdk' Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/swiftc failed with exit code 1 

Mi objective de implementación se configuró originalmente en 8.0, he intentado configurarlo en 9.0, pero eso no hace ninguna diferencia. My Base SDK está configurado en Latest iOS (iOS 9.0).

Esto ocurre en todos mis proyectos Swift, incluso cuando creo un nuevo proyecto, sigo recibiendo este error.

No parece afectar a Objective-C. Una idea que he tenido, ¿podría ser un problema con el SIP deshabilitado? No parece un error de permissions, pero no veo otra razón por la que esto no funciona.

Esto me sucedió cuando instalé simultáneamente Xcode 7 y 6.4 y después de la actualización automática, solo me quedé 7.0.1 .

Una indicación de que algo se xcodebuild -sdk -version fue la salida de xcodebuild -sdk -version :

 xcodebuild[29131:8243992] [MT] DVTSDK: Warning: SDK path collision for path '<DVTFilePath:0x7fac2ae3c800:'/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS9.0.sdk'>': SDK with name 'iphoneos9.0' being superceded by SDK with 'iphoneos9.0'. ... iPhoneOS8.4.sdk - iOS 9.0 (iphoneos9.0) SDKVersion: 9.0 Path: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS8.4.sdk PlatformVersion: 9.0 PlatformPath: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform ProductBuildVersion: 13A340 ProductCopyright: 1983-2015 Apple Inc. ProductName: iPhone OS ProductVersion: 9.0 ... 

Podría haber una forma más fácil de resolver esto, pero reinstalar Xcode 7.0.1 solucionó.

Si no desea volver a instalar Xcode (suposition: está creando para iOS 9), simplemente salga de Xcode y vaya a "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs / "y elimine la carpeta" iPhoneOS8.4.sdk "de ese directory. Asegúrese de hacer una copy externa si todavía la necesita para poder volverla a colocar más tarde. A continuación, reinicie Xcode, limpie y compile. Trabajó para mí