Siempre obtenga un error de compilation: no existe dicho module 'Alamofire'

Seguí las instrucciones de Alamofire en github ,

cocoapods-test un proyecto xcode llamado cocoapods-test y lo cerré.

Voy a la carpeta de proyecto ejecutar el command pod init que genera un Podfile. Luego agregué el siguiente código al Podfile:

 source 'https://github.com/CocoaPods/Specs.git' platform :ios, '8.0' use_frameworks! pod 'Alamofire', '~> 3.0' 

Luego, ejecuto la pod install command y este es el resultado en el terminal:

 Updating local specs repositories CocoaPods 1.0.0.beta.6 is available. To update use: `gem install cocoapods --pre` [!] This is a test version we'd love you to try. For more information see http://blog.cocoapods.org and the CHANGELOG for this version http://git.io/BaH8pQ. Analyzing dependencies Downloading dependencies Installing Alamofire (3.3.0) Generating Pods project Integrating client project [!] Please close any current Xcode sessions and use `cocoapods-test.xcworkspace` for this project from now on. Sending stats Pod installation complete! There is 1 dependency from the Podfile and 1 total pod installed. 

Luego, en mi carpeta de proyecto, hay un nuevo file llamado cocoapods-test.xcworkspace . Hice doble clic en él que abre mi xcode nuevamente, y puedo ver el module Alamofire.

Luego, abrí la class ViewController mi proyecto e import Alamofire . Pero no importa cuántas veces limpie y No such module 'Alamofire' , siempre obtengo un error. No such module 'Alamofire' . Aquí está la captura de pantalla:

introduzca la descripción de la imagen aquí

¿Por qué tengo este problema aunque seguí las instrucciones paso a paso?

(Estoy usando XCode 7.2.1 , Swift 2.1.1 y Alamofire 3.3.0 )

======= ACTUALIZACIÓN ========

Probé la respuesta de @LK Yeung, import Alamofire , luego limpie y compile otra vez, obtuve un montón de errores de comstackdor de Alarmofire:

introduzca la descripción de la imagen aquí

Estaba teniendo este mismo problema. Asegúrese de estar en Xcode 7.3 y usar Swift 2.2.

Puede verificar su versión de Swift usando xcrun swift -version . Actualizar Xcode a 7.3 también debería actualizar Swift automáticamente.

La actualización de Xcode resolvió este problema para mí.

Debe build el proyecto con éxito una vez antes de usar la biblioteca

comentario import Alamofire -> compilation -> descomentar import Alamofire

Puedes probar poner pod 'Alamofire', '~> 3.0' como a continuación. Y vuelva a ejecutar la pod install .

 target 'yourtarget' do pod 'Alamofire', '~> 3.0' end 

Debe agregar la lib a la sección 'La binaria de enlaces con bibliotecas' también.

Tuve el mismo problema, la razón fue porque instalé la versión incorrecta de alamofire.

Estoy usando Xcode 7.3, swift 2.2, así que alamofire 3.0 funcionó para mí

elimine la biblioteca siguiendo estos pasos mencionados por @Michal

Eliminar o desinstalar la biblioteca agregada anteriormente: cocoapods

Luego en su file pod

fuente ' https://github.com/CocoaPods/Specs.git '

plataforma: ios, '9.3' <- su versión objective

use_frameworks!

target '' do pod 'Alamofire', '~> 3.0'

fin

intente con la última actualización instalada alamofire y también revise el uso de alamofire más reciente. Esto es compatible con su xcode.

 source 'https://github.com/CocoaPods/Specs.git' platform :ios, '10.0' use_frameworks! target '<Your Target Name>' do pod 'Alamofire', '~> 4.4' end 

testing esto sobre alamofire en tu podfile