¿Será posible upload a App Store desde Lion?

Otra pregunta se ha cerrado como basada en opiniones: ¿Será posible upload al binary de AppStore realizado en xCode 4 después de iOS 7 y xCode 5?

Ahora mi pregunta es más simple: tengo un iMac a fines de 2006 que solo es capaz de ejecutar Lion. Lo he comprado recientemente para aprender a desarrollar iOS y luego enviarlo a App Store. Ahora que Xcode 5 solo se ejecutará en Mavericks, y iOS 7 lo requerirá, ¿mi dispositivo se volverá inútil pronto, sin poder enviar a la App Store por ningún medio?

¿No debería invertir en el plan de desarrollador, ya que no podré utilizarlo? ¿O hay alguna solución de este problema de compatibilidad?

Lo siento, soy nuevo con Mac. Gracias por las respuestas!

Su León estará bien como se indica aquí:

https://developer.apple.com/support/ios/ios-dev-center.html

"Para desarrollar con iOS SDK y Xcode, debe tener una Mac basada en Intel con Mac OS X Snow Leopard o posterior y debe estar registrado como Apple Developer".


Actualización de julio de 2015

https://developer.apple.com/support/enrollment/

Debe tener una Mac basada en Intel con OS X Yosemite (v10.10) o posterior.

Para su información, Xcode 5 no funcionará en Lion, funcionará con mac versión 10.8.4 en adelante