sendMessage falla en ambas direcciones Apple Watch <-> iPhone en simulador

Estoy construyendo una aplicación para iPhone / Apple Watch. Siguiendo un tutorial en línea , escribí un código para configurar una variable de session tanto en el lado iOS (a través de viewDidLoad () en ViewController) como en el lado del reloj (vía willActivate () en InterfaceController.

Cuando ejecuto las aplicaciones / s en el simulador, el envío de un post desde el reloj al teléfono produce:

Error Domain = WCErrorDomain Code = 7005 "El dispositivo no está emparejado". UserInfo = {NSLocalizedDescription = El dispositivo no está emparejado., NSLocalizedRecoverySuggestion = Vincula el dispositivo con un reloj.}

Al enviar un post desde el teléfono al reloj, se produce:

Error Domain = WCErrorDomain Code = 7006 "La aplicación Watch no está instalada". UserInfo = {NSLocalizedDescription = La aplicación Watch no está instalada., NSLocalizedRecoverySuggestion = Instalar la aplicación Watch.}

El problema es que el simulador informa que los dispositivos del simulador están sincronizados, por lo que el error 7005 parece incorrecto, y la aplicación de reloj está obviamente instalada porque puedo verla en la aplicación Watch en el teléfono, por lo que el error 7006 parece incorrecto. Ninguno de estos errores tiene ningún sentido, y los simuladores de Xcode son tan volubles que no puedo determinar dónde podría estar el problema en la cadena. ¿Puede alguien ofrecer algunas sugerencias?

Parece que me encuentro con este problema (la aplicación Watch no está instalada) con frecuencia, especialmente cuando compongo diferentes versiones de mi aplicación cuando hago sendMessage.

Estoy usando Xcode 7.2.1 y entro en la aplicación Apple Watch en el teléfono y encuentro tu aplicación y apago / encendido: "Mostrar la aplicación en Apple Watch", luego rebuild