Redefinición de cocoapos 'xyz'

Recientemente he actualizado cocoapods a 0.39.0 y xcode a 7.1. Incluso después de actualizar los pods varias veces, obtengo constantemente este error como se muestra en la instantánea.

introduzca la descripción de la imagen aquí

Encontré una misma pregunta planteada aquí.

La respuesta aceptada es utilizar 'cocoapods' que ya estoy usando y la otra respuesta es rebajar la versión cocoapods a 0.38.2. De nuevo siguió este enlace para rebajar los cocoapodos. Pero incluso después de eso, sigo recibiendo el mismo error.

También he intentado eliminar todos los files pod y actualizarlos, tampoco funcionó. ¡Cualquier ayuda es muy apreciada! Gracias.

Eliminar el directory de Derived Data funcionó para mí. Abra Preferences de XCode y vaya a la última pestaña Locations . Haga clic en la flecha pequeña marcada: introduzca la descripción de la imagen aquí

Luego eliminé todo este directory de Derived Data . Volver a ejecutar la aplicación no mostró ningún problema.

introduzca la descripción de la imagen aquí