¿Puedo eliminar las versiones anteriores de soporte de iPhone en la carpeta DeviceSupport en Xcode 4?

En mi búsqueda para descubrir por qué Xcode es tan grande, descubrí que las subcarpetas ocupan gran parte del espacio en la carpeta Developer> Platforms> iPhoneOS.platform> DeviceSupport ..

Como soy (aparentemente) solo se le permite desarrollar para el último de ellos en Xcode, ¿puedo eliminar de manera segura el rest (en este caso 3.0 a 4.2.1)?

La misma pregunta sobre las subcarpetas de Developer> Platforms> iPhoneSimulator.platform> Developer> SDK …

Sí, puede eliminar SKD antes de 4.0 en Developer/Platforms/iPhoneOS.platform/DeviceSupport , es solo un material antiguo.

Para las subcarpetas en Developer/Platforms/iPhoneSimulator.platform/Developer , es la versión de todos los dispositivos que encontrará en iOS Simulator en el menu Hardware> Dispositivo> Versión. A veces puede ser útil mantenerlos para probar la retrocompatibilidad (pero recuerde que una testing en un dispositivo real es aún mejor). Pero si lo desea, también puede eliminar estos SKD.