Proyecto Swift con dependencies Cocoapods

Tengo los siguientes podfiles cocoapods

platform :ios, '8.0' use_frameworks! target 'Foo' do pod "SwiftyJSON", '~> 2.2.0' pod "Locksmith" pod "GoogleMaps" pod "RealmSwift" end target 'FooTests' do end 

También estoy usando cocoapods 0.37.2. Por alguna razón, cuando bash ejecutar la aplicación, se queja con el siguiente error, cuando claramente he especificado que mi proyecto requiere SwiftyJSON 2.2.0 o superior:

  Reason: Incompatible library version: Foo requires version 2.0.0 or later, but SwiftyJSON provides version 1.0.0 

He verificado que no hay otras dependencies en SwiftyJSON (usando cocoapods-dependencies):

 $pod dependencies Dependencies --- - GoogleMaps (1.10.1) - Locksmith (1.2.2) - Realm (0.93.2): - Realm/Headers (= 0.93.2) - Realm/Headers (0.93.2) - RealmSwift (0.93.2): - Realm (= 0.93.2) - SwiftyJSON (2.2.0) 

Como puede ver, nadie tira de SwiftyJSON 1.0.0. Por cierto, la razón por la que estoy usando cocoapods 0.37.2 es debido a este error cuando intenté usar 0.38.1: https://github.com/CocoaPods/CocoaPods/issues/3890 .

¿He extrañado algo aquí (con respecto a la versión desigual de SwiftyJSON)? Intenté limpiar el proyecto, rehacer la installation del pod, etc. sin ningún tipo de suerte.

¡Gracias por adelantado!

Para mí (y para ti parece), lo siguiente funcionó:

  1. Eliminar los pods culpables de podfile (en mi caso, AFNetworking y AFNetworkActivityLogger )
  2. pod install para eliminarlos
  3. Actualice (o rebaje si está en 0.38.1) a cocoapods 0.38.0
  4. Agregar pods atrás e pod install

Ahora estoy de vuelta en el negocio … Creo que 0.38.1 fue el responsable de meterme en este lío.