Problema de signo de código con el proyecto Swift

Tengo el certificate .p12 instalado y un perfil de aprovisionamiento. Cuando ejecuto el proyecto creado en Objective -C, funciona perfectamente en mi dispositivo iOS (ver 7.1), pero cuando ejecuto un proyecto creado en Swift, me lanza un error de señal de código como:

No se pudo codificar /Users/sulabh/Library/Developer/Xcode/DerivedData/FacebookTutorial-fcrwkfacnatqsfcowdihbdhybvhz/Build/Products/Debug-iphoneos/FacebookTutorial.app/Frameworks/libswiftCore.dylib: error de encoding con código de salida 1 Command / Applications / Xcode .app / Contents / Developer / Toolchains / XcodeDefault.xctoolchain / usr / bin / swift-stdlib-tool falló con el código de salida 1

He intentado reinstalar xcode y quitar el certificate de keychain, cambiando la configuration de Build. pero nada funciona para el proyecto Swift. ¿Cuál es el problema y cómo podría solucionarlo?

Debe volver a generar su perfil de aprovisionamiento desde el Centro de desarrolladores de Apple. Por lo que sé, agregan algo nuevo a los perfiles y eso causa el problema.

Para mí, el problema fue que olvidé instalar mi nuevo perfil de aprovisionamiento después de downloadlo. Solo tuve que hacer clic en él para abrirlo en Keychain Access y, de repente, el problema se solucionó.

Asegúrese de que su file de aprovisionamiento contiene el ID de package correcto para su proyecto rápido. Si está utilizando el service push, también verifique si el certificate push service es correcto. Muchos problemas están relacionados con la discrepancia en el id del package.

Además, elija explícitamente el certificate de firma correspondiente y el file de aprovisionamiento para cada proyecto. El uso automático también puede causar problemas.

Probé varias soluciones, y lo que acabó por arreglar fue actualizar Xcode a la última versión (de 7.2.x a 7.3.x).

Cambié el nombre de la disposition anterior y creo un nuevo perfil con nuevo nombre y funcionó bien, por ejemplo, si su nombre de file anterior es APP.mobileprovision cámbielo a APP_New.mobileprovision del website Provisioning de iOS y agréguelo nuevamente

Reinicié Xcode, limpié la carpeta de compilation y comprobé los certificates y aprovisioné los perfiles. Funcionó para mí