¿Por qué estoy viendo "Se ha producido un error al intentar ejecutar el script." En el instrumento de automation de UI?

Cuando bash ejecutar un script de automation de interfaz de usuario en dispositivos con iOS 5, recibo el siguiente error:

"Se produjo un error al intentar ejecutar la secuencia de commands".

introduzca la descripción de la imagen aquí

El mismo script funciona perfectamente en el simulador o en un dispositivo iOS 4.3.3.

¿Como puedó resolver esté problema?

Esto debería solucionar este problema:

sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer 

En dispositivos, debe permitir explícitamente ejecutar secuencias de commands de automation de UI.

  • Vaya a Settings -> Developer
  • Cambiar Enable UI Automation en

Después de activar la opción, el error desapareció y todo funcionó como se esperaba.

Configuración del desarrollador: habilite la automatización de la interfaz de usuario

Intentaría cerrar xcode e iniciar el script de automation sin ejecutar xcode. Tuve un problema en el que el process se adjuntaba a xcode, cuando intentaba ejecutar desde los instrumentos, xcode se atascó en un breakpoint / crash y no pude continuar.

La solución que estoy proponiendo es ejecutar instrumentos independientes de xcode.

Puede ser que tenga más de un Xcode en su máquina, ya sea eliminar otros o simplemente seguir estos pasos

1 Abra Xcode y vaya a sus preferences. 2 Luego, abre la pestaña Ubicación 3 En las herramientas de la command-line, selecciona la versión Xcode que estás usando. es posible que esta input sea incorrecta