Pods-Alamofire: Swift no es compatible con bibliotecas estáticas.

Tengo un proyecto que se ejecuta en Swift 1.2 y iOS 8.4. Después de la actualización de Swift 2 y iOS 9, hice "pod update" para actualizar mis pods. Ahora hay un error de Pods-Alamofire: "Swift no es compatible con bibliotecas estáticas". Alguna idea de cómo solucionar este problema?

¡Agregue use_frameworks! debajo de la plataforma en su file pod. De esta forma, su pod se agregará como marco y no como biblioteca estática.

Si está utilizando cocoapods, asegúrese de que está utilizando la versión correcta de Alamofire

 pod 'Alamofire', '~> 2.0' //2.0 is currently the latest version 

¡También asegúrese de usar use_frameworks! entonces tu perfil debería verse así:

 platform :ios, '8.0' use_frameworks! pod 'Alamofire', '~> 2.0' 

¡The use_framworks! Parte le dice a CocoaPods que su proyecto está utilizando frameworks en lugar de bibliotecas estáticas.

Para usar Pods escritos en Swift, debe include explicitly use_frameworks! para optar por el uso de frameworks. Si olvida include esto, y CocoaPods detecta que está intentando usar Swift CocoaPod, obtendrá un error cuando intente instalar los pods.

Si alguna vez ha progtwigdo en Swift, esto puede parecer un poco extraño, porque el Podfile está escrito en Ruby. No es necesario que conozcas a Ruby para usar CocoaPods, pero debes tener en count que incluso los errores de text menores normalmente harán que CocoaPods arroje un error.

Crédito: Ray Wenderlich