phonegap 2.0 en ios tiene un error

Mi código funciona bien en la plataforma Android (phonegap 2.0 y antes). Pero cuando bash ejecutarlo en iOS, tiene algunos problemas. Si agrego cordova2.0.js así:

<script type="text/javascript" src="js/cordova-2.0.0.js"></script> 

Pero mi aplicación alertará mucho. como estas:

["Información", "Estado de networking0", verdadero]

["tDeviceInfo", "Device1", true]

Cuando romove la label cordova-2.0.0.js. El index.html se carga normalmente sin ninguna alerta. No sé por qué.

Tuvimos un problema similar que se solucionó utilizando siempre cordova-2.0.0 que xCode crea automáticamente para usted al iniciar un proyecto de directory telefónico.

¿Estás usando la versión de Android del javascript?

Prueba usar la biblioteca cordova para ios. Parece que estás usando el Android, o el path está mal.