No se puede instalar Xcode 4.6.2 en OS X Mavericks

No puedo instalar Xcode 4.6.2 en OS X Mavericks. Actualicé de Mountain Lion a OS X Mavericks y funcionaba durante ese time. Lo desinstalé porque pensé que se estaba comportando de una manera extraña y cuando intenté volver a instalar, obtuve el error "Xcode no se puede instalar en" Macintosh HD "porque la versión de OS X es demasiado nueva".

Busqué este error en línea y las personas recomendaron borrar el caching pero eso no ayudó.

Siguió el paso en el sitio de Apple, pero eso tampoco solucionó el problema.

No estoy seguro de por qué está sucediendo.

Editar:

Parece que fue un problema localizado con mi propio Xcode y Mavericks. La actualización a 5 lo arregló para mí, pero parece que no funciona para otros.