No se puede ejecutar la installation de pod – error de permiso

He estado intentando ejecutar el proyecto de alguien pero no puedo instalarlo.

pod install Analyzing dependencies Pre-downloading: `KNMultiItemSelector` from `https://github.com/kentnguyen/KNMultiItemSelector.git` Downloading dependencies Installing AFNetworking (2.5.1) Installing Amplitude-iOS (2.2.4) Installing Analytics (1.11.2) Installing AppsFlyer-SDK (2.5.3.10) Installing Bugsnag (4.0.3) [!] Error installing Bugsnag [!] /usr/bin/git submodule update --init Submodule 'KSCrashModule' (git@github.com:bugsnag/KSCrash.git) registenetworking for path 'KSCrashModule' Cloning into 'KSCrashModule'... Permission denied (publickey). fatal: Could not read from remote repository. Please make sure you have the correct access rights and the repository exists. Clone of 'git@github.com:bugsnag/KSCrash.git' into submodule path 'KSCrashModule' failed 

Probé varias sugerencias diferentes sobre Stack Overflow, etc., y aún así me topo con esto. ¿Alguien tiene alguna otra idea?

Tengo el mismo problema Yo sigo

  1. Comprobación de las keys SSH existentes ( https://help.github.com/articles/checking-for-existing-ssh-keys/ )

  2. Agregando su key SSH al agente ssh ( https://help.github.com/articles/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent/#adding-your -ssh-key-to-the-ssh-agent )

  3. y luego ingrese la contraseña correcta de las keys SSH.

  4. "pod install" de nuevo, es trabajo.

Terminé de eliminar el podfile "Bugsnatcher" y reinstalarlo. Tuve otro error con un podfile diferente después, pero también lo reinstalé. Proyecto construido después de eso.