No se puede ejecutar en el dispositivo después de instalar iOS 4.2 y 4.2 SDK.

Instalé iOS 4.2 en mi iPod Touch de segunda generación la semana pasada. Intenté ejecutar mi aplicación en el dispositivo a través de Xcode, pero no funcionó (porque Xcode aún no admitía iOS 4). Para resolver eso, instalé Xcode 3.2.5 y iOS SDK 4.2. Ahora puedo hacer que la aplicación se ejecute en el iPhone / iPad Simulator muy bien.

Sin embargo, ya no puedo seleccionar "Dispositivo" del menu en la parte superior de la pantalla. Es una opción, pero cuando trato de hacer clic en él, nunca obtiene una marca de verificación.

No se puede seleccionar el dispositivo en el menú XCode.

Debido a esto, ya no puedo ejecutar la aplicación en mi iPod. El otro problema (relacionado) es que no puedo elegir "Crear y archivar" desde el menu Generar más porque el objective no es un dispositivo.

¿Por qué está pasando esto? ¿Debo cambiar algunas configuraciones en mi proyecto, o algo con mi dispositivo en sí mismo?

EDIT: Tras una investigación más detallada, parece que no puedo seleccionar nada más que el iPhone Simulator 4.0. Tal vez haya algo mal en el file del proyecto.

Verifique que el SDK base esté configurado en Último iOS (actualmente configurado en iOS 4.2) para su proyecto Xcode y el producto de su objective, luego realice una reconstrucción y vea si su iPod es reconocido.

También intente visitar Xcode Organizer y ver si está pidiendo algo desde su iPod. Por lo general, Xcode querrá recostackr algunos datos de dispositivos cuyo sistema operativo reciba actualizaciones, para que pueda actualizarse e instalar sus aplicaciones en el sistema operativo actualizado correctamente.