No se puede actualizar Xcode 4.2. Error: consulte var / log / install.log para get más detalles.

ACTUALIZACIÓN : como esta pregunta está obteniendo algunas vistas, pensé que sería mejor destacar el hecho de que resolví el problema simplemente volviendo a download Xcode desde la Mac App Store . Al volver a instalarlo, incluso me dio una opción práctica para eliminar la versión anterior y replacela por la nueva. ¡Esperemos que esto ayude a todo el mundo con el mismo problema! 🙂

Estoy intentando actualizar mi Xcode 4.2 que descargué de la tienda de aplicaciones, pero recibo este error cuando uso el actualizador 'Instalar Xcode.app':

introduzca la descripción de la imagen aquí

Alguien sabe lo que estoy haciendo mal o cómo solucionarlo?

No estoy realmente seguro de qué otra información debo proporcionar, así que por favor, házmelo saber si quieres más información 🙂

Edit: Aquí está el install.log completo (creo): http://pastebin.com/GTzkpL3X

Este es un extracto que realmente muestra el error:

Failed install preflight: Error Domain = PKInstallErrorDomain Code = 102 "El package" DeveloperTools.pkg "no es de confianza". UserInfo = 0x7f9d5da29060 {NSLocalizedDescription = El package "DeveloperTools.pkg" no es de confianza., NSURL = .. / Packages / DeveloperTools.pkg – file: //localhost/Applications/Install%20Xcode.app/Contents/Resources/Xcode.mpkg /, PKInstallPackageIdentifier = com.apple.pkg.DeveloperToolsLeo, NSUnderlyingError = 0x7f9d5d9eab40 "La operación no se pudo completar. CSSMERR_TP_CERT_EXPIRED"}

abra la date y hora de las preferences del sistema y establezca la date un año antes (en mi caso, tal vez la date preferible podría ser la date anterior a la publicación de Xcode 4.3) y mi installation se completó con éxito.

El siguiente error aparece en el logging:

 Error Domain=PKInstallErrorDomain Code=102 "The package “DeveloperTools.pkg” is untrusted." UserInfo=0x7f9d5da29060 {NSLocalizedDescription=The package “DeveloperTools.pkg” is untrusted. PKInstallPackageIdentifier=com.apple.pkg.DeveloperToolsLeo, NSUnderlyingError=0x7f9d5d9eab40 "The operation couldn't be completed. CSSMERR_TP_CERT_EXPIRED"} 

Mirando por Internet encontré las siguientes sugerencias:

  1. Aplanando el package

    http://managingosx.wordpress.com/2012/03/24/fixing-packages-with-expinetworking-signatures/

  2. Actualice el software de su sistema:

    https://apple.stackexchange.com/questions/45771/xcode-4-2-install-for-snow-leopard-fails-with-an-openglapps-pkg

  3. Reinstalar el SO:

    https://discussions.apple.com/thread/3827920

    https://discussions.apple.com/thread/2616364

  4. Eliminar files relacionados con Xcode:

    https://discussions.apple.com/thread/3828043

editar: reorderado según los comentarios.