No estoy seguro de cómo convertir mi Swift 1.2 a 2.0 o si debería

En primer lugar, si escribo una aplicación en swift2 y la envío a la tienda de aplicaciones. ¿Estará disponible / funciona para personas que todavía ejecutan iOS 8?

En este momento, he escrito una aplicación usando swift 1.2. Pero no sé cómo convertirlo en swift 2. ¿Debo actualizar por primera vez mi podfile para usar pods con swift 2.0 y luego ejecutar la installation de pods y luego ejecutar el código migrator en xcode para actualizar mi propio código?

Gracias por adelantado,

Puede utilizar la última versión de Swift, y se creará y ejecutará en cualquier versión de iOS que comience con iOS7. Seguramente querrías migrar a Swift 2 porque está muy mejorado.

Cocoa pods es un problema aparte, pero debe usar la última versión que funcione con la última versión de Swift.

Establezca el Objetivo de implementación en la versión más baja del sistema operativo que desea admitir, y Xcode presentará un error si intenta usar algo (por ejemplo, una llamada de API) que no es compatible.

introduzca la descripción de la imagen aquí