marco no encontrado FirebaseAnalytics

Agregué Google Analytics por CocoaPod en mi proyecto, pero mi aplicación se bloqueó y me dio el siguiente error.

ld: framework not found FirebaseAnalytics clang: error: linker command failed with exit code 1 (use -v to see invocation) 

¿Qué debo hacer para resolver este problema? Seguí este tutorial de google para integrar Google Analytics en mi proyecto.

Probablemente uses cocoapods para agregar Firebase. Asegúrate de que en la configuration de compilation para tu objective, las 'Rutas de búsqueda del marco' para Depurar y Liberar comiencen con $(inherited) .

La configuration de compilation para las dependencies de pod está definida en un file xcconfig, si no tiene $(inherited) en la configuration de compilation de su destino, se ignorará la configuration de este file.

Debe eliminar el framework vinculado de las properties del proyecto.

Tuve el mismo error, mis Framework Search Paths en Build Settings ya estaban configuradas en $(inherited) para Depurar y Liberar.

Logré resolver esto con la solución aquí: https://stackoverflow.com/a/38246169/1092815

En otras palabras, Podfile.lock tenía algunas versiones malas, corriendo esto resolvió mi problema:

 pod update pod install 

Tal vez ya haya agregado otra configuration de Framework Path Path to Build,

 Step 1: Remove all frame work search path in Build setting Step 2: run Pod install Step 3: Add others Framework search path (That's removed in step 1). 

¡Ahora ejecuta el proyecto!