ld: Framework no encontrado

Tratando de instalar Alamofire a través de Cocoapods. Esta es una nueva aplicación con cero configuration. Tengo la pod install la aplicación y abrir el proyecto a través de su espacio de trabajo. Recibir el siguiente error usando XCode 7.1.

 ld: framework not found Alamofire clang: error: linker command failed with exit code 1 (use -v to see invocation) 

Podfile

 # Uncomment this line to define a global platform for your project source 'https://github.com/CocoaPods/Specs.git' platform :ios, '9.0' # Uncomment this line if you're using Swift use_frameworks! target 'Bitcoin Watcher' do pod 'Alamofire', '~> 3.1' end target 'Bitcoin WatcherTests' do end target 'Bitcoin WatcherUITests' do end 

Pods.framework se encuentra en mis Linked Frameworks and Libraries . Esto es absolutamente frustrante, ya que he probado numerosas soluciones, pero ninguna funciona. La versión Cocoapods es 0.39 .

debe recordar que cuando instala una nueva versión de Xcode, antes de actualizar / instalar la pod, primero debe hacer la installation de sudo gem install cocoapods . Esto actualizará todas las gems que podrían haber sido eliminadas debido a la actualización de Xcode.

Luego, recuerde el siguiente paso: no debe haber ningún fiel en el espacio de destino relacionado con sus dependencies, mencionado en el pod. Esto confundirá su Xcode sobre los files relevantes para usar para usar la dependencia.

Por lo tanto, asegúrese de que los files de dependencies se mencionan solo en la carpeta de pods.

A continuación, recuerde que en la configuration de ruta de enlace, debe usar el primer $inherited para especificar la ruta de acceso de las bibliotecas.

Este paso debe hacerse antes de instalar cualquier dependencia.

Por último, cmd+ Shift +k -> Limpiar el proyecto se debe hacer antes de usar el pod Install desde el terminal.

Jason en su caso xcode no puede enlazar framework, por lo que se menciona en los pasos anteriores.

Espero que responda todas sus preguntas

Si está creando un proyecto para tvOS, debe especificar

 platform :tvOS, '9.0' 

en lugar. No sé si esto solucionará todos los problemas, pero te acercará con security.

Si está utilizando Cocoapods, verifique la versión y la actualización, limpie y ejecute la aplicación

 sudo gem install -n /usr/local/bin cocoapods pod install pod update