La pantalla de inicio en Xamarin.iOS no se muestra. Se muestra una pantalla azul

Estoy teniendo problemas para mostrar una pantalla de inicio solo en mi dispositivo iPad Mini real. Cuando ejecuto mi aplicación, se muestra una pantalla azul. Estoy usando un catálogo de activos para include las imágenes. ¡Cuando corro en iPhone o en iPad 2 Simulators, la pantalla de inicio muestra perfectamente! Dentro del file Contents.json en mi catálogo de activos, hay 4 imágenes para iPad. Son:

– Default-portrait.png (768×1004)

– Default-Portrait@2x.png (1536×2008)

– Default-Landscape.png (1004×768)

– Default-Landscape@2x.png (2008×1536)

La opción Estilo de barra de estado "Ocultar durante la ejecución de la aplicación" dentro de info.plist no está marcada.

He seguido los pasos Administrar pantallas de inicio con catálogos de activos en la guía de pantalla de inicio de Xamarin: http://developer.xamarin.com/guides/ios/application_fundamentals/working_with_images/launch-screens/#asset-catalogs

Si alguien sabe cuáles son mis errores, ¡házmelo saber! =]

PD: ¡Perdón por el mal inglés!

Al igual que James Montemagno y Kevin Mullins respondieron en esta publicación Launch Screen , los nuevos dispositivos iOS necesitan usar Storyboard en lugar de Assets Catalogs. Creo un Storyboard y funciona perfectamente ahora.

Puede verificar las letras mayúsculas / minúsculas correctas. El simulador no distingue entre mayúsculas y minúsculas, por ejemplo, acepta con gusto un file defAULT-PORtrait.png. Su dispositivo iOS, por otro lado, distingue entre mayúsculas y minúsculas.

Más específicamente, noté que sus files se llaman:

  • Default- p ortrait.png (768×1004)
  • Default- P ortrait@2x.png (1536×2008)

Tal vez le resulte útil duplicar la ortografía de todos los files y catálogos de activos para asegurarse de que sean consistentes con su file info.plist.