La implementación de Visual Studio iOS falla porque "el module de borde no se ha precomstackdo"

Estoy tratando de implementar una aplicación HTML / CSS / JS Apache Cordova desde una máquina de Windows a una Mac. Creo que se están comunicando correctamente a través del agente de remotebuild pero cuando bash build un proyecto en blanco para desplegarlo en Mac, este error se arroja al comienzo de la compilation:

MDAVSCLI : error : The edge module has not been pre-compiled for node.js version v4.1.1. You must build a custom version of edge.node. Please refer to https://github.com/tjanczuk/edge for building instructions. 

He seguido el enlace y he buscado la solución de cómo solucionar este error, pero el enlace no parece aplicarse a lo que estoy haciendo. No estoy usando ninguna function node.js en mi código, así que estoy confundido acerca de por qué ocurre este error. Solo estoy tratando de crear una página HTML casi en blanco y todavía obtengo el error, independientemente de cuán simple hago la página.

¿Cómo puedo solucionar esta solución? ¿Cuál es la mejor manera de deshacerse de este error o porque el error sugiere que el borde de precompilation funcione con node.js versión 4.1.1?

@Dustin,
Tienes una idea errónea de cómo funciona Cordova. Dices que quieres implementar en una Mac , pero creo que te refieres a iOS. Si es así, debe leer:

¿Qué se necesita para el desarrollo de iOS?
https://groups.google.com/forum/?fromgroups=#!topic/phonegap/bf1Hgkel3W4

Yo cito

Lo breve y dulce de esta es la siguiente:

  • Necesitas OS X + Xcode
  • Necesitas varios iDevices
  • Necesita $ 99 / año para el progtwig Apple Developer (que ya indicó no es un problema)

Todo lo anterior = costo de hacer negocios.

Si lees todo el hilo (especialmente la parte de Kerri Shotz), obtendrás más información y más opciones.

La mejor de las suertes

Después de perder un poco de esperanza y de seguir una gran cantidad de publicaciones, blogs y errores sin solución de continuidad, decidí hacer clic en el button "Ejecutar el Verificador de Dependencias" en Visual Studio – Herramientas -> Opciones -> Herramientas para Apache Cordova – > Herramientas Cordov. Este corrector me dijo que Joyent Node.js se instaló. Tenía node.js y npm configurados en la última versión, no estoy seguro de cuál es la diferencia.

Pasé por el process de modificar la installation de VS (cambiar o eliminar un progtwig) y, por supuesto, Joyent Node.js no fue verificada. Lo revisé y pasó por el process de installation.

Mi installation VS ahora se ve como la siguiente y mi proyecto se está desarrollando sin:

 MDAVSCLI : error : The edge module has not been pre-compiled for node.js version v4.1.1 

introduzca la descripción de la imagen aquí