La actualización de CocoaPods está degradando un pod instalado

Cuando ejecuto la pod update , MMDrawerController se está degradando desde la versión instalada actualmente (0.5.7) a una versión anterior (0.4.0).

Aquí está el contenido de mi Podfile:

 source 'https://github.com/CocoaPods/Specs.git' link_with 'OpenEye-Mobile', 'SecurityStar Tests' platform :ios, '7.0' pod 'AFNetworking', '~> 2.5.0' pod 'MBProgressHUD', '~> 0.9' pod 'MMDrawerController' pod 'MMDrawerController+Storyboard', '~> 0.0.1' pod 'UIAlertView+Blocks', '~> 0.8.1' target :"SecurityStar Tests" do pod 'OCMock', '~> 3.1.1' end 

Acabo de actualizar la gem de cocoapods de v. 0.34.4 a 0.35.0. El único cambio que he hecho al Podfile es actualizar AFNetworking de 2.3.1 a 2.5.0. Si trato de especificar explícitamente MMDrawerController como v. 0.5.7, obtengo un error de dependencia:

 - `MMDrawerController (= 0.5.7)` requinetworking by `Podfile` - `MMDrawerController (~> 0.4.0)` requinetworking by `MMDrawerController+Storyboard (0.0.1)` 

¿Que está pasando aqui? ¿Por qué este es un problema de repente? ¿Algo cambió algo en cocoapods 0.35? ¿Hay alguna forma de forzar que MMDrawerController+Storyboard esté bien con MMDrawerController (= 0.5.7) ?

SOLUCIÓN 1 es especificar el mismo range que en MMDrawerController + Storyboard

 pod 'MMDrawerController', '~> 0.4.0' 

SOLUCIÓN 2 es actualizar MMDrawerController + Storyboard podspec para que utilice la última versión.

EXPLICACIÓN El problema es como dice: error de dependencia.

Esta línea en un podfile significa tomar lo último (para 04.02 es 0.5.7):

 pod 'MMDrawerController' 

Mientras que este exige 'MMDrawerController + Storyboard':

 pod 'MMDrawerController+Storyboard', '~> 0.0.1' 

que, a su vez, especifica en su podsec como una dependencia:

 s.dependency 'MMDrawerController', '~> 0.4.0' 

'~> 0.4.0' significa que puede usar las versiones 0.4.0 – 0.4.9 y no hay intersección de 0.5.7 con 0.4.0 – 0.4.9.