iphone: enviar aplicación con iOS 5 y XCode 4.2?

Tengo una aplicación que está construida en XCode 4.2 (vista previa del desarrollador) y iOS 5, con el objective de implementación iOS 4.0. No estoy usando ninguna de las características de iOS 5.0. ¿Puedo enviar esta versión a apple? ¿O es un problema porque es beta? ¿Debo volver a Xcode 4.02 y buildlo en 4.3?

Nunca debería instalar beta builds SDK como su SDK primario y la versión de XCode. Mantenga siempre la installation actual en / Desarrollador (o donde lo desee) e instale la versión beta en alguna otra location (/ iOS5Beta como ejemplo). Con esto, cuando llegan las nuevas versiones beta de XCode y el SDK, puede desinstalar la versión / iOS5Beta e instalar la nueva (puede que no tenga que desinstalar, sino solo un punto).

Esto le permite probar la versión beta, luego, bajo la installation / desarrollador, realice su desarrollo habitual.

Cuando el GM está fuera, instala eso bajo / Desarrollador y listo.

Nunca envías Apps a Apple con versiones beta de XCode y los SDK.

Todos los files readme que recuerdo para las versiones beta de Xcode han dicho que no se pueden usar para su envío. Tienes que usar una versión GA de Xcode para enviar aplicaciones.