Articles of cocoapods

CocoaPods Error (PubNub) con iOS Static Library Project

Estoy trabajando en iOS Static Library Project (9.0). Decidí include PubNub en mi proyecto de biblioteca estática. Pasos que seguí; He descargado el proyecto de ejemplo PubNub y he creado. He copydo los files Framework (CocoaLumberjack y PubNub) en mi carpeta de Archivos de Soporte. Cerré xCode y creó PodFile en el directory del proyecto. […]

CocoaPods: no se puede encontrar una especificación para `GoogleMaps`

Soy nuevo en iOS, ya tengo Alamofire y MarqueeLabel en mi Podfile y ahora, tratando de agregar GoogleMaps , sigue mostrando este post, [!] Unable to find a specification for `GoogleMaps` Mi Podfile parece a esto # Uncomment the next line to define a global platform for your project source 'https://github.com/CocoaPods/Specs.git' platform :ios, '9.0' target […]

¿Cuál es el verdadero significado de link_with en Podfile?

Mi pregunta es que no sé qué sucede realmente después de usar link_with en mi Podfile, así que no sé cuándo y dónde usarlo. He leído la guía pero la descripción es breve para saber el significado de link_with . Después de mi testing, sé que si utilizo link_with sin target en mi Podfile, la […]

Instalar vainas de cocoa en mavericks

Interpreté a los rebeldes esta mañana en mi mac, pero parece que ha hecho algo con gems de Ruby … Cuando escribo: sudo gem install cocoapods Se rompe con error: ERROR: Error installing cocoapods: ERROR: Failed to build gem native extension. /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby extconf.rb mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/include/ruby.h Navegué en la […]

Cocoa Pods necesita reinstalar completamente.

El background Soy un poco nuevo en Unix proveniente de un entorno .NET pero ahora sé lo suficiente como para meterme en problemas. Obtuve un código existente con el que estoy usando cocoapods, así que traté de instalar Cocoapods. Inicialmente, cuando lo instalé falló diciendo que requiere una versión más nueva de Ruby. Para instalar […]

Obtener error inesperado cocoapod instalar pods

Tenía los pods funcionando bien hasta que intenté instalar otro pod y comencé a recibir un extraño error, no he hecho ninguna actualización y funcionaba perfectamente hasta hace poco. Podfile platform :ios, '8.0' target 'Wireless' do pod 'TapjoySDK', '~> 10.2' pod 'MBProgressHUD', '~> 0.9.1' pod 'IQDropDownTextField', pod 'PayPal-iOS-SDK', pod 'DLRadioButton' end Mensaje de error que […]

Error de Cocoa Pods con la installation del pod.

[!] No se puede satisfacer los siguientes requisitos: Google/SignIn por Podfile Google/SignIn por Podfile Google/SignIn por Podfile Google/SignIn por Podfile Google/SignIn (= 1.3.2) requerido por Podfile.lock Se encontraron especificaciones que satisfacían la dependencia de Google/SignIn , pero requerían un objective de implementación mínimo más alto. Se encontraron especificaciones que satisfacían la dependencia de Google/SignIn , […]

Especificar GCC_PREPROCESSOR_DEFINITIONS para un cocoapod de Podfile

Estoy usando la biblioteca MTDates para algunos cálculos de dates en mi aplicación. Y, por supuesto, se agrega a mi proyecto como cocoapod . MTDates agrega methods como mt_startOfCurrentHour a NSDate . Pero también tiene una opción para usar nombres de método sin mt_ prefix. Solo startOfCurrentHour . Para habilitarlo, necesitamos definir un macross de […]

Error al instalar Cocoapods 0.35.0

Estoy intentando instalar Cocoapods versión 0.35.0 con el siguiente command: sudo gem install cocoapods –version 0.35.0 Cuando trato de verificar la versión con pod –version Obtuve el siguiente error: ——————————————— Error loading the plugin with path `/Library/Ruby/Gems/2.0.0/gems/cocoapods-try-0.4.5/lib/cocoapods_plugin.rb`. NoMethodError – undefined method `tmpdir' for Dir:Class /Library/Ruby/Gems/2.0.0/gems/cocoapods-try-0.4.5/lib/pod/command/try.rb:66:in `<class:Try>' /Library/Ruby/Gems/2.0.0/gems/cocoapods-try-0.4.5/lib/pod/command/try.rb:8:in `<class:Command>' /Library/Ruby/Gems/2.0.0/gems/cocoapods-try-0.4.5/lib/pod/command/try.rb:5:in `<module:Pod>' /Library/Ruby/Gems/2.0.0/gems/cocoapods-try-0.4.5/lib/pod/command/try.rb:4:in `<top (requinetworking)>' /Library/Ruby/Site/2.0.0/rubygems/core_ext/kernel_require.rb:121:in `require' […]

Alamofire no puede build con cocoapods

Estoy usando: OSX 10.11.3 Xcode 7.21 cocoapods 0.39.0 Aquí está mi podfile source 'https://github.com/CocoaPods/Specs.git' platform :ios, '9.0' use_frameworks! pod 'Alamofire', '~> 3.0' Cuando bash build mi proyecto, Alamofire tiene 23 errores. Ejemplo aleatorio: expected ':' after case Intenté reiniciar xcode, limpiar, build, build solo alamofire, rm -rf ~/Library/Developer/Xcode/DerivedData , pero todos con el mismo resultado. […]