iOS: Error de encoding: formatting de package no reconocido, no válido o inapropiado en el subcomponente Base.lproj

Tengo un proyecto que estaba funcionando bien. Al parecer random, hacer una ejecución una vez resultó en un error de código que no he podido resolver durante 2 días.

El error dice:

package de formatting no reconocido, no válido o inadecuado En el subcomponente: /Users/user/Library/Developer/Xcode/DerivedData/…/Base.lproj

No estoy seguro de por qué surgió este error. Puede haber sucedido después de que seleccioné un 'Equipo' en Xcode, pero no puedo recordar (y no sé por qué eso causaría un problema). Traté de limpiar mi llavero, creando el identificador de package en mi count de desarrollador, un puñado de commands de terminal de otras publicaciones, en vano.

Lo extraño para mí es que parece indicar que tiene algo que ver con Base.lproj, que contiene solo la punta de LaunchScreen y mi main.storyboard. ¿Podría haber algo en Storyboard que está causando un problema de código de identificación? ¿Algo más? LLAMADA DE SOCORRO.

Esta es una gran puñalada en la oscuridad, pero obtuve este error cuando agregué un directory llamado "resources". Eliminarlo solucionó el problema por mí.

Me encontré con el mismo problema con Xcode 7.3.1 y cocoapods. Terminé haciendo lo siguiente:

1. Xcode cerrado

2. Eliminé todo en mi carpeta DerivedData

rm -fr / Usuarios / {usuario} / Biblioteca / Desarrollador / Xcode / DerivedData / *

3. Reestableció Xcode y reconstruyó el proyecto.

Recibí este error cuando agregué el script que arreglaba un error de llavero -34018 que apareció por primera vez en XCode 6.3.

#!/bin/sh codesign --verify --force --sign "$CODE_SIGN_IDENTITY" "$CODESIGNING_FOLDER_PATH" 

Si está utilizando CocoaPods, entonces actualice CocoaPods y luego todos los pods funcionaron de mi parte.

sudo gem update cocoapods seguido de pod install