iOS App Archive La entrega falló con errores aunque los numbers de versión son correctos y superiores a los anteriores

Mi versión aprobada anterior fue 1.0.1 y estoy intentando enviar una nueva versión con la versión número 2.0.1.

ERROR ITMS-90478: "Versión no válida. La compilation con la versión" 101 "no se puede importar porque se ha cerrado una versión posterior para las nuevas comstackciones. Elija un número de versión diferente."

ERROR ITMS-90062: "Este package no es válido. El valor de la key CFBundleShortVersionString [2.0] en el file Info.plist debe contener una versión superior a la de la versión aprobada previamente [101]".

introduzca la descripción de la imagen aquí

Mi versión aprobada anterior fue 1.0.1

No lo creo. El post de error es claro y no constring con las afirmaciones que haga en su pregunta. Tenga en count que no dice nada acerca de "1.0.1". Hablas (en tu pregunta) sobre "1.0.1", pero iTunesConnect dice "101". Creo que iTunesConnect, no tú.

Claramente, entonces, lo sopló y envió una versión "101". Bueno, "2.0.1" es menor que "101", porque se analiza como una cadena de versión y "2" es menor que "101".