¿Instalar cocoapodos viejos?

Todo mi proyecto es wack actualmente porque ninguna de las dependencies cumple con cocoapods 1.0. No solo millones de Podspecs no funcionan, también hay muchos otros problemas que solían ser advertencias y que ahora generan errores de detención … tan frustrantes.

He intentado eliminar ~/.cocoapods , sudo gem uninstall cocoapods y sudo gem install cocoapods -v 0.39.0 y se están produciendo los mismos errores. ¿Parece que lo está instalando de todos modos o algo así?

 cocoapods (0.39.0) cocoapods-core (1.0.0, 0.39.0) cocoapods-deintegrate (1.0.0) cocoapods-downloader (1.0.0, 0.9.3) cocoapods-plugins (1.0.0, 0.4.2) cocoapods-search (1.0.0, 0.1.0) cocoapods-stats (1.0.0, 0.6.2) cocoapods-trunk (1.0.0, 0.6.4) cocoapods-try (1.0.0, 0.5.1) 

¿Cómo utilizo la versión 100% antigua hasta que se reparen estas libs?

Paso 1 Ejecute sudo gem install cocoapods -v 0.39.0 , esto instalará la versión que desee.

Paso 2 Ejecute la sudo gem list , que le dará una list de todas las gems que ha instalado, así como su versión; notará que tiene instaladas varias versiones de cocoapods.

Paso 3 Desinstalar la (s) versión (es) que no quieres con sudo gem uninstall cocoapods -v 1.0 .

Paso 4 Confirma que ahora estás ejecutando la versión correcta de cocoapods con pod --version .