Este iPhone 6 está ejecutando iOS 10.1 (14B55c), que puede no ser compatible con esta versión de Xcode

Estoy intentando ejecutar la aplicación después de actualizar Xcode a v8 y iOS a v10, pero este post de error aparece y me impide hacerlo:

Este iPhone 6 está ejecutando iOS 10.1 (14B55c), que puede no ser compatible con esta versión de Xcode.

introduzca la descripción de la imagen aquí ¿Qué debo hacer para deshacerte de esto?

Para utilizar iOS 10.1 beta necesitas usar Xcode 8.1 beta. Xcode 8 no es compatible con iOS 10.1 beta.

Y ahora que iOS 10.1 y Xcode 8.1 están fuera de beta, asegúrese de actualizar a la versión más reciente, no beta de ambos.

La actualización Xcode 8.1 ya está disponible en la tienda de aplicaciones, por lo que debe actualizar su Xcode a la última versión : https://itunes.apple.com/us/app/xcode/id497799835?mt=12


Parece que iOS 10.1 se lanzó hoy, pero no Xcode 8.1. Si actualizó sus dispositivos a 10.1, necesitará download Xcode 8.1 GM Seed para desplegar en sus dispositivos con iOS 10.1.

Puede download el 8.1 GM Seed aquí: https://developer.apple.com/download/

Generalmente, GM Seed es la versión final que se lanza a la tienda de aplicaciones.

La versión pública de Xcode 8 no es compatible con iOS 10.1 beta. Apple lanzó versiones beta de macOS Sierra 10.12.1 e iOS 10.1 hace unos días. Pero watchOS, tvOS y Xcode no están incluidos en las betas públicas de Apple.

Necesita Xcode 8.1 GM para usar su dispositivo 10.1. PERO es realmente absurdo lanzar una nueva versión de iOS sin lanzar la versión correspondiente de Xcode. Algo realmente raro.