ERROR ITMS-90534: "Cadena de herramientas inválida

ERROR ITMS-90534: "Cadena de herramientas no válida.

Las nuevas aplicaciones y las actualizaciones de la aplicación deben crearse con las versiones públicas (GM) de Xcode 6 o posterior, macOS y iOS SDK o posterior. No envíe aplicaciones creadas con software beta que incluyen versiones beta macOS. " ERROR ITMS-90534: "Invalid Toolchain . Las nuevas aplicaciones y las actualizaciones de la aplicación deben crearse con las versiones públicas (GM) de Xcode 6 o posterior, macOS y iOS SDK o posterior. No envíe aplicaciones creadas con software beta que incluyen versiones beta macOS ".

Encontré este error al upload IPA a la count.

El mismo problema ocurre conmigo hoy ( 13 July 2017 ).

Como estaba usando XCode 9 beta 2 , hasta la date. Todo estaba funcionando bien.

La última compilation que subí fue el 9th of July 2017 , usando XCode 9 beta 2 .

Después de probar muchos cambios, finalmente la solución fue:

Actualización a la última beta de XCode , que fue XCode 9 beta 3 (lanzada el 10th July 2017 ).

LÍNEA DE FONDO:

Si está utilizando cualquier versión beta de XCode , y si está desactualizado . Apple rechazará su compilation de esa versión y provocará el error que le hizo el interlocutor. Siempre que la versión sea estable no necesita preocuparse.

Se recomienda comprobar si su versión actual es la última o no. Si no es así, descargue el XCode más reciente y presione una nueva compilation que se haya obtenido utilizando la versión más reciente de XCode beta

¿Por qué no utilicé una versión estable de XCode en su lugar?

La versión estable en este momento es XCode 8.3.3 , y el lenguaje utilizado es Swift 3 .

Aunque hay un cambio mínimo en el código de Swift 3 to 4 , pero mi última base de código fue Swift 4 . Además, es posible que tenga Pods en su proyecto, que también debe degradarse a la última versión estable. Hasta que no exista una versión estable de XCode 9. Entonces, opto por download la última versión de XCode beta

Estaba teniendo el mismo problema con la versión pública de Xcode 8.3. Instalé el Xcode y lo comprobé, pero no funcionó …

Finalmente encontré el problema, he seleccionado erróneamente Xcode 3.2-compatible en formatting de proyecto en el documento del proyecto. Lo cambié a compatible con Xcode 8.0 y lo compilé y archivé. Podría uploadlo sin ningún error. Compruebe la captura de pantalla adjunta ..

introduzca la descripción de la imagen aquí

Un post de error que dice, usa una versión estable (no beta) de Xcode para crear una compilation. Su Mac OS también debe ser estable (no beta)

Utilice la última versión estable de Xcode Tool (Xcode 9) para crear su compilation y cargarla usando el Cargador de aplicaciones.

Asegúrate de los siguientes puntos, mientras creas tu compilation:

  • Versión Xcode (última versión estable de Xcode Tool – Xcode actual 9)
  • Versión de Mac OS (última versión estable de MacOS – High Sierra 10.12.7)
  • Proyecto Xcode (Documento) Versión de formatting (compatible con Xcode 8.0)

Cada cosa se actualizó con Xcode 8.3.3, OS Serra 10.12.6 pero todavía estaba recibiendo el problema. Lo que hice y el problema se resolvió es:

Abrir la tienda de aplicaciones buscadas xcode Abrir Xcode desde la tienda de aplicaciones me instó a instalar algunas funciones que faltan. Seguí las instrucciones y completé el asistente Re-abrir Xcode y archivé mi aplicación y luego comencé subido y se ejecutó correctamente.

Espero que pueda ayudar a alguien.

¡Aclamaciones!

Finalmente pude resolver este problema descargando XCode 8.2.1 desde App Store.

Re-archivando el proyecto y presentando como de costumbre.