Error de iOS: la biblioteca no se encuentra para -lGSDK_Overload

Después de la actualización de pod, veo el siguiente error

biblioteca no encontrada para -lGSDK_Overload

mientras intentaba build el proyecto. He estado usando Google Analytics en mi proyecto. ¿Esto está relacionado con Google Analytics? Ver la ruta de búsqueda de encabezado en mi proyecto

introduzca la descripción de la imagen aquí

He visto las preguntas similares en SO. Pero aquí no tengo idea de qué es GSDK y dónde radica el problema real.

Detalles de la actualización del pod.

introduzca la descripción de la imagen aquí

Cualquier ayuda será apreciada

Comtesting las siguientes soluciones

  1. ¿Has lanzado tu proyecto a través de [project_name].xcworkspace

  2. libGSDK_Overload_external.a file de biblioteca libGSDK_Overload_external.a en la siguiente ruta de acceso de file-path/[project_name]/Pods/GoogleSymbolUtilities/Libraries/ en su carpeta raíz del proyecto y agregue este file al destino de proyectos. Reconstruye tu proyecto

introduzca la descripción de la imagen aquí

  1. Si el problema aún sale, elimine el file pod y vuelva a instalarlo.

Después de algunas horas de probar la respuesta provista por @ vje1998 y un par de cosas más, como borrar datos derivados, eliminar todos los cocoapods. Finalmente lo solucioné. Espero que esto ayude a cualquiera que pueda tener el mismo problema.

En Build Settings>Linking>Other Linker Flags . Eliminé la fila con -lGSDK_Overload. Resolvió el problema de que Google Analytics todavía funciona y no hay errores de linker. Después de ejecutar la pod install Other Linker Flags permanece igual, asumiendo que no era necesario para comenzar.

Tuve un problema similar:
biblioteca no encontrada para -lPods

Lo arreglé con la opción de respuesta 3 de Rohit Agre

pod deintegrate
rm -r [project_name].xcworkspace
pod install