Error de enlace Xcode después de actualizar a la versión 8.0

Mi proyecto no se comstack con un error: el linker command failed with exit code 1 (use -v to see invocation) and description

ld: … / Xcode / DerivedData / Acoustic-ejrjwtwpmnimpdaazezbknffdbim / Build / Products / Debug-iphonesimulator / Result.framework / Resultado comstackdo con la versión más reciente del lenguaje Swift (3.0) que los files anteriores (2.0) para la architecture x86_64 captura de pantalla

El problema está en el marco de ReactiveCocoa, creo. Se agrega como submodule a mi proyecto. Utilizo solo Objective-C y no puedo entender cómo resolver este problema.

"Debe configurar explícitamente la bandera Usar lenguaje henetworkingado Swift en el objective CocoaPod. Esto puede hacerse haciendo clic en el proyecto Pods, haciendo clic en el objective RealmSwift, yendo a la pestaña 'Configuración de compilation', y cambiando el indicador a Sí "

Para leer más, entra aquí

Necesita actualizar CocoaPods a una versión más reciente compatible con XCode 8 (CocoaPods 1.1.0 o posterior):

 sudo gem install cocoapods 

Luego haz una actualización de pod para arreglar tus dependencies que no están vinculadas:

 pod update 

Elimine la carpeta DerivedData para su proyecto y reconstruya, el error del enlace debería desaparecer.

Estaba enfrentando el mismo problema pero estaba relacionado con otro marco no con Realm.

Proyecto -> Destino -> Usar versión de lenguaje henetworkingado rápido ->

introduzca la descripción de la imagen aquí

Siempre recomendaría actualizar tus proyectos usando el asistente proporcionado. Si no apareció, puede convertir su código manualmente desde el menu Editar> Convertir> A la syntax rápida actual. Tal vez esto ayude.

De lo contrario, Apple proporciona una buena guía de migration aquí: Migración a Swift 2.3 o Swift 3 desde Swift 2.2 Quizás esto te ayude.

Esta pregunta ya se hizo aquí: no se puede build un proyecto con xcode 8 beta 6