Error de compilation RestKit y AFNetworking

Cuando bash importar la API de RestKit en un proyecto, obtengo el siguiente error:

/Documents/Code/RestTest/RestKit/Code/Network/RKHTTPRequestOperation.h:21:9: 'AFNetworking.h' file not found 

He instalado RestKit como un submodule git, ¿cómo resuelvo la dependencia de RestKit en AFNetworking?

Una vez clonado, simplemente hazlo en el directory de RestKit:

 git submodule update --init --recursive 

Esto sacará las necesidades de la versión AFNetworking RestKit.

Si usa CocoaPods hará todo esto automáticamente.

De los documentos de installation de RestKit:

Instale CocoaPods si aún no está disponible:

$ [sudo] gem instalar cocoapods
$ pod setup

Edite su Podfile y agregue RestKit:

$ editar Podfile
plataforma: ios, '5.0'
pod 'RestKit',: git => 'https://github.com/RestKit/RestKit.git',: branch => 'development'

Las testings y la búsqueda son componentes opcionales.

pod 'RestKit / Testing',: git => 'https://github.com/RestKit/RestKit.git',: branch => 'development'
pod 'RestKit / Search',: git => 'https://github.com/RestKit/RestKit.git',: branch => 'development'

Instale en su proyecto:

$ pod install

Tenga en count que si su installation falla, puede deberse a que está instalando con una versión de Git más baja de lo que CocoaPods espera. Asegúrese de ejecutar Git> = 1.8.0 ejecutando git –version. Puede get una image completa de los detalles de la installation ejecutando la installation de pod –verbose.

Esto puede ayudar a algunas personas. Salté por completo esta sección en el wiki RestKit específicamente dirigido a evitar los errores de AFNetworking:

https://github.com/RestKit/RestKit/wiki/Installing-RestKit-v0.20.x-as-a-Git-Submodule#updating-the-precompiled-header-file

Tuve un 'AFNetworking.h' file not found y fue porque me perdí estas importaciones en el file .pch.