Error de command / bin / sh con código de salida 1 y marco de pods embedded

No se pudo identificar un problema real. Durante la actualización de coco pod, se obtuvo un post " Re-creación de CocoaPods debido a la actualización de la versión principal " (que se realizó solo una vez) y la actualización de la pod se realizó correctamente. Después de la compilation obtengo el error. Falló el command / bin / sh con el código de salida 1 . A continuación hay algunos detalles que también estoy recibiendo

  1. Code Signing /Users/Gaurav/Library/Developer/Xcode/DerivedData/Appname-******/Build/Products/Debug-iphoneos/Appname.app/Frameworks/Alamofire.framework with Identity iPhone Developer: Account Name (Account Id)
  2. /usr/bin/codesign --force --sign ***************** --preserve-metadata=identifier,entitlements "/Users/UserName/Library/Developer/Xcode/DerivedData/Appname-***************/Build/Products/Debug-iphoneos/Appname.app/Frameworks/Alamofire.framework"
  3. /Users/Username/Library/Developer/Xcode/DerivedData/Appname-************/Build/Products/Debug-iphoneos/Appname.app/Frameworks/Alamofire.framework: bundle format unrecognized, invalid, or unsuitable

Estoy usando iOS 8 como destino de implementación y Xcode 7.3.1. He verificado la identidad de la firma de código que no tiene ningún problema. He reinstalado nuevamente todas las pods y Alamofire también pero no abel a problema identificado.

Limpiar el proyecto y eliminar los datos derivados (~ / Library / Developer / Xcode / DerivedData /) lo solucionó para mí

Si se quejaba de un Pod en particular y no podía codificarlo.

A continuación funcionan las cosas para mí:

  1. Seleccione el Proyecto Pods. En la window del editor principal, select el Pod en el menu desplegable de destinos.
  2. En la pestaña general y bajo el encabezado de identidad, click el file Info.plist
  3. Seleccione el file Plist para el Pod.

El proyecto ahora debe buildse. Por alguna razón, parece perder esta configuration, o no poder hacer reference a su propio file Plist.

No estoy 100% seguro pero espero que ayude a alguien.

Tengo el mismo problema. Sucede después de actualizar CocoaPods, por lo que acabo de degradarlo y todo funciona bien. Creo que solo tenemos que esperar a una nueva versión de cocoaPods y por ahora puedes usar la versión anterior. Cómo rebajar el cocoaPods