¿En qué casos se envió el error CloudKit CKErrorIncompatibleVersion?

La documentation dice que:

CKErrorIncompatibleVersion

La versión de la aplicación es menor que la versión mínima permitida.

Disponible en iOS 8.0 y versiones posteriores.

Pero no da muchos detalles sobre qué context podría causar que se reciba este error. No hay forma de establecer una versión de aplicación mínima permitida, por lo que sé.