El time de ejecución del simulador iOS 8.1 no está disponible en Xcode 6.1

Estaba usando Xcode 6.0.1 hasta ahora y las cosas estaban bien. Luego, pasé a Xcode 6.1 e intenté ejecutar mi aplicación (que tiene un objective de deployment de 7.0) en el simulador iPhone 6. Pero muestra un post de error:

El time de ejecución del simulador iOS 8.1 no está disponible . Descargue el time de ejecución del simulador iOS 8.1 desde la sección Descargas en las Preferences de Xcode

Eliminé manualmente el Xcode anterior (6.0.1) e instalé 6.1 desde un dmg. Intenté search pero no pude encontrar cosas relacionadas. Cualquier ayuda sería apreciada.

Captura de pantalla de advertencia

Es un problema de Mac, no un problema de Xcode.

Cierre session, cierre, reinicie o simplemente reinicie Mac. Su simulador Xcode volverá a la normalidad.

Reiniciar no me ayudó.

¡Instalar / reinstalar simuladores funcionó!

Mire debajo (Preferences de XCode-> Descargas -> Componentes)

Reiniciar mi computadora solucionó este problema exacto para mí. Se lanzó el mismo error para simuladores de iOS7 y iOS8. Estoy en OS X 10.10 y Xcode 6.1.

Mantener una list precisa de simuladores de iOS.

Al actualizar, puede arrastrar antiguos simuladores que ya no están disponibles con su versión actual de Xcode. Puede limpiar estos ejecutando este command en Terminal :

xcrun simctl delete unavailable 

Salga de Xcode primero solo por buenas medidas. De la documentation:

Eliminar un dispositivo o todos los dispositivos no disponibles.

Acabo de tener este problema con Xcode 8 beta 5. Descargué simuladores ios8 y 9, pero no pude ejecutar mi aplicación. Simplemente eliminé los datos derivados y reinicié mi computadora. Funcionó para mí.