El selector no reconocido de error pushwoosh enviado a la instancia Cordova 1.7.0

Estoy probando pushwoosh y traté de anular el logging de un dispositivo iOS en la API remota y surgió este error:

-[__NSDictionaryI cdvjk_JSONString]: unrecognized selector sent to instance *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '- [__NSDictionaryI cdvjk_JSONString]: unrecognized selector sent to instance *** First throw call stack: libc++abi.dylib: terminate called throwing an exception Sending request: {"request":{"hwid":"my_hwid", "application":"my_app_id"}} To urL https://cp.pushwoosh.com/json/1.3/pushStat (lldb) 

Entonces me di count de que el método de anulación se implementa solo para los androids y no para los dispositivos iOS, por lo que los complementos pushwoosh no estaban utilizando la request en la carpeta de complementos.

Eliminé el código de mis files index.js y pushnotifications.js, pero el error siempre aparecía cada vez que intentaba iniciar la aplicación después de aceptar una notificación push.

Luego quité este código del api remoto:

  new JObject( new JProperty("custom", "json data"))), new JProperty("link", "http://pushwoosh.com/") 

con la esperanza de que los datos aparentemente personalizados no se envíen a pushwoosh.

Aún aparece el error. Sé que el problema es que se realiza una request sin ayuda cada vez, pero el problema es que el código no existe.

¿Podría haber editado algunas firmas de methods y estas firmas se están utilizando cada vez que trato de aceptar una notificación push?

¿O es que Xcode realiza autocomplete?

Necesito a alguien que esté familiarizado con pushwoosh (y Xcode) para ayudarme aquí. ¿Cuál sería la solución sin tener que actualizar a Cordova 2.1.0 o posterior desde (Este error proviene del plugin en sí, los chicos de Phonegap han cambiado la forma en que se llama a la function de objective -c "JSONString" agregando el prefijo "cdvjk_" rompiendo la compatibilidad de los complementos con cualquier versión de <Phonegap <2.1.)?

Lea este hilo. Desafortunadamente, esto es un error para los chicos de PhoneGap, que hicieron imposible admitir tanto Cordova 2.1 como versiones anteriores:

https://github.com/shaders/phonegap-cordova-push-notifications/issues/12

Puede contactar al equipo de Pushwoosh preguntando si aún pueden ayudarlo con las versiones anteriores.