El post de cadena de herramientas no es válido aunque la aplicación no se haya enviado con software beta

Estoy intentando enviar un proyecto a la tienda de aplicaciones. Accidentalmente lo abrí en la versión más reciente de Xcode Beta, pero no guardé ni cambié nada.

Envié la aplicación con Xcode 7.3.1 y cuando bash enviar la aplicación para su revisión, recibo el post: "New apps and app updates must be built with the public (GM) versions of Xcode 6 or later, macOS, and iOS SDK. Don't submit apps built with beta software including beta macOS builds."

Si reviso el Info.plist del file, también me menciona usando la versión pública de Xcode

 <key>DefaultToolchainInfo</key> <dict> <key>DisplayName</key> <string>Xcode 7.3.1 Default</string> <key>Identifier</key> <string>com.apple.dt.toolchain.XcodeDefault</string> </dict> 

La versión beta de Xcode no estaba abierta al enviar y también intenté reiniciar y volver a enviar. Por cierto, estoy ejecutando El Cap 10.11.6

¿Qué puedo hacer para arreglar esto?

Gracias

¿Instaló la actualización de security de ayer? Tengo una teoría, que esta actualización alteró el número de versión interna de 10.11.6 (15G31) a 10.11.6 (15G1004), y no han agregado este número de versión a la list de comstackciones de SO estable permitidas en iTunes Connect.

Bastante seguro es la actualización de security.

Probé el conocido hack de alterar la compilation del SO a 15G31 en SystemVersion.plist, pero esto ya no parece funcionar. Reinstalar Xcode 7.3.1 también fue una pérdida de time.

Por suerte, tenía una máquina que aún no había hecho Actualización de security 2016-001. Mover el código allí, archivado y subido, y esto fue bien.

Recibí el mismo problema y el problema se solucionó : ¡envié mi aplicación para su revisión con éxito hace 5 minutos!

¡Fue porque el equipo de iTunes no se sincronizó con la última actualización de security de la versión macOS y terminaron la synchronization justo ahora!

¡Adelante, testing a reenviar tu aplicación!

Estoy viendo esto también, hubo una actualización de security reciente para El Cap que podría estar relacionada, o Apple está en el process de hacer cambios para iOS 10 Xcode 8 y ha arruinado algo.

Si necesita enviar, me gustaría presentarla y si recibe un rechazo, entonces explíquelo a Apple.

He cargado mi binary iOS instalando El Capitan en una máquina virtual, desactivando las actualizaciones del sistema, instalando Xcode, importando mi perfil de desarrollador y creando allí mi aplicación.

Acabo de 2 a 3 horas descargando la base El Capitan (10.11.6) de App Store y configurando VMware Fusion para build nuestro proyecto en … incluyendo la regeneración manual y el cambio de todos los certificates y los perfiles de aprovisionamiento dos veces (hasta allí y de vuelta a la máquina host).

Puedo concluir que esto resuelve el problema porque el instalador de App Store El Capitan aún no incluye la actualización de security, que bombea el número de compilation macOS a uno que NO está incluido en la list blanca de iTunes Connect, como algunos han sugerido.

Súper frustrante, pero al less hay una solución disponible por ahora. 😖

Eche un vistazo a las notas de la versión de Xcode y vea si su versión de Xcode tiene: "Se ha depreciado el soporte para files de aplicaciones", como hizo la mía.