El objective 'Pods-App' tiene dependencies transitivas que incluyen binarys estáticos cuando se usa GTM en un marco rápido

Estoy intentando volver a trabajar una parte de un proyecto rápido 3 para convertirlo en un marco rápido para utilizarlo como una vaina. La cuestión es que necesito usar legado de GoogleTagManager (v3) como una dependencia y obtengo el siguiente error al hacer la pod spec lint :

ERROR | [iOS] desconocido: encontró un error desconocido (el objective 'Pods-App' tiene dependencies transitivas que incluyen binarys estáticos: (/ private / var / folders / 7t / 0cd0n1gn46xd7r1cywrgcy2w0000gn / T / CocoaPods / Lint / Pods / GoogleTagManager / Libraries / libTagManager .a)) durante la validation.

O con GTM v5:

ERROR | [iOS] desconocido: encontró un error desconocido (el objective 'Pods-App' tiene dependencies transitivas que incluyen binarys estáticos: (/ private / var / folders / 7t / 0cd0n1gn46xd7r1cywrgcy2w0000gn / T / CocoaPods / Lint / Pods / GoogleTagManager / Frameworks / GoogleTagManager .framework)) durante la validation.

Estoy usando la última versión de cocoapods (1.1.0.rc.2) y, por lo que entendí, el problema proviene de las dependencies del module GTM, que al less una es una biblioteca estática.

Leí algunos hilos en los que las personas hablan de soluciones para instalar bibliotecas estáticas dentro de un marco o para envolver bibliotecas estáticas en un marco al crear un module. La cosa es que la biblioteca estática es una dependencia del module GTM, así que no tengo control sobre él. Al less eso es lo que entendí aquí .

Aquí está mi Podfile:

 # Uncomment this line to define a global platform for your project platform :ios, '8.0' target 'MyProject' do # Comment this line if you're not using Swift and don't want to use dynamic frameworks # use_frameworks! # Pods for MyProject pod 'GoogleTagManager', '~> 3.15.2' end 

y aquí está mi (abreviado para StackOverflow) MyProject.podspec:

 Pod::Spec.new do |s| s.name = "MyProject" s.version = "0.1.0" s.platform = :ios, '8.0' s.ios.deployment_target = '8.0' s.source_files = "MyProject", "MyProject/**/*.{h,m}", "MyProject/**/*.{swift}" s.dependency 'GoogleTagManager', '~> 5.0.0' end 

Ya intenté download el GTM SDK e instalarlo sin cocoapods, pero supongo que me perdí un paso porque no pude hacerlo funcionar.

Así que me gustaría get algunos consejos sobre mis files podsec y podfile, o una explicación sobre cómo instalar el SDK sin cocoapods. Muchas gracias !