El module comstackdo con swift 4.0 no se puede importar en swift 3.1

Aparentemente he logrado build mi proyecto en Xcode 9 beta y ahora solo obtengo el error

El module comstackdo con swift 4.0 no se puede importar en swift 3.1

Cuando ejecuto el proyecto en Xcode 8. El module en mi caso es Alamofire. He intentado reiniciar Xcode, pero no pasa nada, ¿hay alguna idea de cómo resolver este problema?

Tiene dos opciones que puede hacer:

Clean el proyecto y luego intente re-build su solución y vea si funciona.

Si no funciona y sigue recibiendo el mismo post de error, realice los siguientes pasos y debería funcionar para usted:

  1. Abre tu podfile y elimina Alamofire
  2. Ejecutar pod update
  3. Vuelva a agregar Alamofire a su podfile
  4. Ejecutar pod update
  5. Cuando esto haya terminado, clean su proyecto y ejecútelo

El mismo problema aquí pero usando Carthage. Y aquí está la respuesta:

  • rm -rf ~/Library/Caches/org.carthage.CarthageKit/DerivedData
  • borre la carpeta Carthage para el proyecto
  • Actualizar Carthage: carthage update --platform iOS

Y voilà!

Tuve el mismo problema y la limpieza de la carpeta de compilation me ayudó:

 Command+Option+Shift+K 

o

Product -> Option+Clean

Solo eliminar los datos derivados funcionó para mí, no es necesario volver a instalar Pod