¿El file pod no se inicializa?

Cuando bash inicializar el file pod para usar cocoapods vía terminal, me da este error. Cómo solucionarlo, gracias de antemano.

 /Library/Ruby/Gems/2.0.0/gems/cocoapods-1.2.0/lib/cocoapods/command.rb:128:in `verify_minimum_git_version!': [!] You need at least git version 1.8.5 to use CocoaPods (Pod::Informative) 

Me encuentro con el mismo problema y lo resuelvo usando el siguiente command:

 sudo xcode-select --switch /Applications/Xcode.app 

Como muestra el post de error en la terminal , algo con mi git sale mal. Y tiene que ver con la herramienta de command-line.

Tenía un problema al intentar instalar packages con cocoapods. He intentado "sudo xcode-select --switch /Applications/Xcode.app" todavía recibiendo un error de ruta incorrecto

Para solucionar esto

Abrí Xcode

 Preferences Locations Selected the Command Lin Tools: Xcode 8.3 

Ahora, cuando instalo packages con cocoapods, ya no recibo errores.

Si ha actualizado su MAC desde App Store, debe ejecutar: xcode-select –install

Cuando ejecuté git –version antes de ejecutar el command anterior, no encontró git en absoluto. Se muestra este error: falta xcrun en: / Library / Developer / CommandLineTools / usr / bin / xcrun . Entonces, supongo que cuando actualicé mi máquina de alguna manera perdí git. Independientemente, funcionó el command anterior funcionó.

Luego ejecuté git –version y mostró la versión git que estaba instalada.

Referencia: http://tips.tutorialhorizon.com/2015/10/01/xcrun-error-invalid-active-developer-path-library-developer-commandline-tools-missing-xcrun/

Oye esto te puede ayudar !!! Seguí este enlace

https://stackoverflow.com/a/16664135/7905401

Después de instalar las herramientas de command-line, lo cerré y volví a abrir el terminal ahora cuando comprobé la versión git – ¡la versión me dio la versión de actualización 2.10.0 y luego ejecuté otros commands para Cocoapod! ¡¡¡¡¡¡¡¡¡esta funcionando!!!!!!!!! yeeeii !!!!

Seguí esto

Después de instalar las herramientas de línea de command, lo cerré y abrí el terminal nuevamente. Ahora cuando comprobé la versión git --version , me dio la versión de actualización 2.10.0, luego ejecuté otros commands para cocoapod .

Ahora está funcionando.