El equipo seleccionado no tiene una membresía del Progtwig para desarrolladores de iOS

Estoy intentando agregarme como desarrollador en un equipo para iOS. (Es un progtwig universitario)

Ingreso a Xcode, selecciono el nombre del equipo y hago clic en "arreglar el problema" (anteriormente tenía problemas de firma de código, que solucioné). Devuelve este error: "El equipo seleccionado no tiene una membresía del Progtwig para desarrolladores de iOS"

Esto es falso, estoy seguro de que el equipo es un equipo de desarrollo de iOS. Y en developer.apple.com me muestra como conectado en el equipo de iOS. Xcode simplemente no reconocerá este hecho. Por favor ayuda.

(Video del problema: http://screencast.com/t/mu5mV8WmD )

Recibí este error cuando la count de desarrollador de Xcode estaba usando una dirección de correo electrónico de id de Apple anterior. Eliminar esa count de Xcode y volver a agregarla resolvió el problema por mí.

Tuve este problema después de que cambié la contraseña a mi count de id de Apple, parece que de algún modo no puede solicitar sus datos sobre su count y certificate. Por lo tanto, es "Seleccionar un equipo con una membresía del Progtwig para desarrolladores de iOS y volver a intentarlo".

Confirme que eliminar la count de Xcode y agregarla resuelve el problema.

Si cambió su contraseña, vaya a Xcode: preferences y cambie la contraseña en la count correspondiente.

Lo que funcionó para mí fue eliminarlo y agregarlo nuevamente como se sugirió anteriormente (no estoy seguro si es necesario) y luego seleccionar otro equipo, y luego seleccionar el original nuevamente. Si solo eres miembro de un equipo, solo tendrás que eliminarlo y agregarlo nuevamente.

así es como he resuelto el mismo problema. Tenía una count de membresía válida. Pero no lo reconoció. Asi que;

  • He hecho que el equipo no tenga ninguno en (General / Identidad)

  • Luego limpia el proyecto

  • Se cambió el perfil de Provisión a Automático en (Comstackción / Código de firma)

  • la parte más importante (había agregado el dispositivo usando su ID en (membercenter / Devices)

  • He agregado una nueva count usando (General / Identidad) (testing esto si no funciona la selección de la count anterior desde aquí)

  • Luego, he iniciado la aplicación y funciona en el dispositivo real.

Espero eso ayude

De hecho, tengo esto arreglado. Acabo de hablar con mi administrador de counts, y me agregó como un nuevo proyecto bajo la count de la universidad, que resolvió mi problema. Esto fue lo que solucionó mi problema, así que lo estoy marcando como la respuesta. Sin embargo, estoy seguro de que las otras respuestas y comentarios aquí probablemente también lo ayudarán a suponer que tiene problemas similares.

Esto me sucedió cuando iTunes Connect se apagó. Tenía la sensación de que estaba abajo porque rastreaba el error de nuevo a las cnetworkingenciales de la count mala, y Twitter confirmó mis sospechas.