Después de instalar XCode 7 ya no puedo crear y ejecutar proyectos porque el documento no se puede abrir

EDIT: Esta pregunta se refiere a la versión preliminar de XCode 7, por lo tanto, puede no ser relevante si está ejecutando la versión actualmente publicada, ya que algunos problemas pueden haberse solucionado.


Obtengo lo siguiente:

No se pudo conectar con el agente de iOS. Por favor, presente un informe de error en bugreport.apple.com.

introduzca la descripción de la imagen aquí

¿Porqué es eso?

Si miro los detalles que recibo:

=================================

ERROR:

Error al search o crear context de ejecución para la descripción Contenido del sistema 1x para IBCocoaTouchFramework-EightAndLater con fidelidad pnetworkingeterminada (razón de falla: el software causó la interrupción de la connection): no se pudo encontrar el time de ejecución del simulador más nuevo disponible . (Motivo de falla: no se pudo establecer una connection al service de verificación del simulador).

Error Domain = NSPOSIXErrorDomain Code = 53 "Error al search o crear context de ejecución para la descripción Contenido del sistema 1x para IBCocoaTouchFramework-EightAndLater con fidelidad pnetworkingeterminada" UserInfo = 0x7fcf5961ebd0 {NSLocalizedDescription = No se pudo encontrar o crear context de ejecución para la descripción Contenido del sistema 1x para IBCocoaTouchFramework- EightAndLater con fidelidad pnetworkingeterminada, NSUnderlyingError = 0x7fcf58b72950 "No se pudo encontrar el time de ejecución del simulador más nuevo disponible"}

Me encontré con el mismo problema con xcode 7 beta 3.

Tenía mi objective de implementación establecido en 8.3. Establecerlo en 9.0, limpiar la compilation y reiniciar xcode funcionó para mí.

Intente eliminar y reinstalar su Xcode beta, funcionó para mí en Xcode beta 3

Parece que este es un problema común. Encontré una respuesta en los foros de desarrolladores de Apple:

https://forums.developer.apple.com/thread/11706

En caso de que el enlace no funcione o no tenga acceso, esta es la respuesta aceptada:

Respuesta correcta por seancook el 21 de julio de 2015, 5:58 p.m.

Experimenté esto también en El Capitán. Los NIB no se cargarían, no existirían Sims, y no podrían iniciar simuladores a través del menu Xcode / Open Developer Tool / Simulator. Después de pelear por unas pocas horas, finalmente lo puse en funcionamiento. Esto es lo que funcionó para mí (YMMV): noté un post en Console.app a lo largo de las líneas del time de ejecución de Simulator que no era el código firmado. Fui a la ruta que describió "/ Library / Developer / CoreSimulator / Profiles / Runtimes" y eliminé los times de ejecución que tenía allí. Fueron viejos times de ejecución, así que supongo que alguna verificación en Xcode ahora se aplica que antes no. ¿Quién sabe?
Después de hacer esto, finalmente pude ejecutar el Simulador a través del menu Xcode / Open Developer Tool. Lamentablemente, el simulador aún no se muestra como un destino de ejecución en mi espacio de trabajo, por lo que seguí espeleándolo … Luego ingresé al menu Hardware / Dispositivos / Gestionar dispositivos del Simulador y agregué un nuevo dispositivo iOS9. No parecía hacer nada, así que salí de Xcode y Simulator.app. Luego volví a iniciar Simulator.app (a través de Xcode / ODT / Simulator) y he aquí los simuladores de iOS9 esperados. Cerré y reabrí Xcode, cambié el SO objective para mi proyecto y finalmente los Sims se mostraron como objectives de ejecución.

HTH

Verifique que tiene la última installation de Xcode Beta con Xcode-beta, click "Acerca de Xcode" y verifique el número de compilation.

A continuación, compruebe el número de compilation actual de la versión más reciente de Xcode-beta en la página de descargas de Xcode:

https://developer.apple.com/xcode/downloads/

Obtuve este error con la compilation de versiones de Xcode 7.0 (7A220). Yo también estaba ejecutando el dispositivo y no estaba usando el simulador.

Hice una opción Limpiar carpeta de construcción … Limpiar , cerrar Xcode y luego abrir Monitor de actividad. Encontré un montón de processs de Ibtool en ejecución. Terminé todos estos y reinicié Xcode.

¡Todo va de nuevo!

No estoy seguro de qué respuesta aceptar como para mí lo que funcionó fue instalar una beta posterior (beta 5). Había presentado un error a Apple hace un par de meses, así que supongo que resolvieron este problema actualizando Xcode.

Alguien que experimente esto con el lanzamiento oficial actual?

Publico esto como respuesta por ahora, pero si alguien tiene una explicación más detallada, estaré encantado de eliminar mi respuesta y aceptar la tuya.

En primer lugar, su traza de stack no muestra nada relevante con la respuesta que encontré, sin embargo, mi traza de stack también me pareció irrelevante. Pero funcionó para mí y espero que funcione para usted:

Alguien del equipo de Apple dio la respuesta en: https://forums.developer.apple.com/thread/3978

Lo que se dijo es: "Vimos esto en los laboratorios de WWDC. El locking fue causado por un selector de color personalizado que ofendió. Intenta eliminar cualquier selector de color personalizado que hayas instalado en tu sistema"

En resumen, elimine el selector de color relacionado de su sistema, cierre el código xcode y vuelva a iniciar.