Después de actualizar a Xcode 6.3, los files de la aplicación iOS recién construida no se pueden enviar.

Después de actualizar a 6.3 y crear un file para mi aplicación iOS, el file aparece debajo de "Otros elementos" y "Enviar a la tienda de aplicaciones" está atenuado.

Mis files construidos antes de la actualización se enumeran correctamente bajo el nombre de la aplicación.

Noté que funciona correctamente para la versión Mac de mi aplicación.

Intenté cambiar el nombre del objective y el nombre del esquema de la versión de iOS para que todos coincidan con el nombre en Aplicaciones de iOS en el Organizador, pero eso no ayudó (¡si solo las cosas fueran tan simples!).

Ventana de archivos

Resolución de Apple

Por ejemplo, mi aplicación "Tripla" tiene un proyecto principal y un subproyecto (Google-API-client: GTL.xcodeproj). En el proyecto principal, tiene un objective principal y 4 subobjects, y en el GTL.xcodeproj, tiene 4 objectives.

La installation de salto en la pestaña "Configuración de construcción" en la configuration del proyecto principal es SÍ, pero NO en el subproyecto y todos sus sub-objectives.

La installation de salto en la pestaña "Configuración de construcción" en el objective principal del proyecto principal es SÍ, pero NO en el rest de los sub-objectives.

Resolvió este problema de mi aplicación "Tripla".

Apple soluciona problemas técnicos TN2215

Finalmente noté que se estaba creando un "Archivo Genérico". Consulté esta pregunta: No se puede generar el file de la aplicación iOS en xcode

Mi configuration para INSTALL_PATH ("Directorio de installation") se estableció en $(HOME)/Applications . Lo configuré al valor pnetworkingeterminado, /Applications , y eso solucionó el problema. Marcaría esto como un duplicado de la pregunta vinculada, pero alguien podría encontrar el mismo problema después de actualizar Xcode (algo obviamente cambiado).

Si la respuesta anterior no funciona para usted, aquí está lo que me resolvió. Puede ser un problema debido a la actualización de CocoaPods

La actualización a Cocoapods 38.2 y la ejecución de 'pod install' solucionó el problema para mí.

La respuesta es mi caso fue degradar cocoapods. Utilizando Xcode 7 y cocoapods 0.39.0.beta.4, degradado a beta 3.

Consulte esta respuesta para get instrucciones completas: https://stackoverflow.com/a/32654636/146738